1. Chú ý: Các bạn nên tham khảo Nội quy trước khi viết bài (click vào liên kết bên dưới).
    * Nội quy và Thông báo diễn đàn CNCProVN.com
    * Nếu bạn thấy hứng thú với bài viết. Hãy dùng chức năng Share to facebook để chia sẻ bài viết lên facebook.
Trang 1 của 2 12 CuốiCuối
Kết quả 1 đến 20 của 21

Chủ đề: lỗi mất bước đều , do ARTCAM hay do Mach3 đây??

  1. #1
    Thợ cả biết tuốt's Avatar
    Ngày tham gia
    Nov 2013
    Đang ở
    Hanoi, Vietnam, Vietnam
    Bài viết
    1,356
    Cám ơn
    534
    Được cám ơn 437 lần ở 319 bài viết

    lỗi mất bước đều , do ARTCAM hay do Mach3 đây??

    thưa các bác em đang trong giai đoạn vọc artcam , bản em dùng là artcam pro 9 và mach3 v 3.20
    em gặp cái lỗi như sau:
    em khoét thử 1 hình vuông 10x10cm , sâu 8mm
    các bước em làm trong art : dùng công cụ Area clear để khoét , và chạy ngang theo trục x (Raster =0)
    lúc máy chạy nó bị dịch trục x dần đều sang bên trái , để lại như rộng bậc thang
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	loi.JPG 
Views:	1 
Size:	1.14 MB 
ID:	709
    em tưởng DRiver của em bị lỗi em kiểm tra , đổi trục này sang trục kia vẫn rứa --> chán đnag định mua đồ mới về thử
    ai dè em lại cho nó khoét lại và chạy theo trục y (Raster =90)
    thế là lần này trục x ngon trục y bị lỗi như trục x , như vậy có nghĩa là driver của em không sao
    vậy các bác chỉ cho em biết là do artcam lỗi hay mach3 lỗi vậy?
    còn một lỗi nữa của mach3 là đang chạy mà em ấn Estop , sau đó reset và ấn star thì nó nhẩy đi 20 dòng lệnh rồi chạy chứ không chạy ở dòng vừa dừng là sao các bác nhỉ???
    Lần sửa cuối bởi biết tuốt, ngày 11-11-2013 lúc 03:54:31 PM.

  2. #2
    Thợ bậc 3
    Ngày tham gia
    Oct 2013
    Bài viết
    56
    Cám ơn
    45
    Được cám ơn 45 lần ở 18 bài viết
    Bác down file nầy về dùng dao end mill 6 mm chạy trên cục phôi có kích thước 120x120x12 mm xem ra hình gì rồi post lên đây !
    test.nc

    Down về chạy xong chụp hình up lên nhé !
    Chấp Nhận Thua 1 Trận Chiến Nhưng Sẽ Thắng Cả Cuộc Chiến .

  3. #3
    Thợ bậc 6 CKD's Avatar
    Ngày tham gia
    Nov 2013
    Bài viết
    4,409
    Cám ơn
    940
    Được cám ơn 3,749 lần ở 1,902 bài viết
    @biết tuốt

    Bạn dùng driver gì? BOB gì? config mach3 ra sao?
    Chạy nhanh & chậm đều như thế này hết hay chạy chậm không bị?
    Theo mình nghĩ đây là sai bước sau mỗi lần đảo chiều? Nếu biết được driver, BOB, sơ đồ đấu dây có thể tìm ra nguyên nhân.
    Phạm Duy Anh - Email: phamduyanh@gmail.com - DT: O9O8984O1O - CKD's Youtube Channel -> click here - Facebook
    121A Mậu Thân, p.Xuân Khánh, q.Ninh Kiều, tp CT

  4. #4
    Spam killer ahdvip's Avatar
    Ngày tham gia
    Nov 2013
    Đang ở
    Ho Chi Minh City, Vietnam, Vietnam
    Bài viết
    934
    Cám ơn
    103
    Được cám ơn 562 lần ở 304 bài viết
    Theo em phần nhiều là do máy có vấn đề chứ không phải file.
    Anh đánh dấu điểm trước khi chạy đi, chạy xong nó về home anh ra lại chỗ đó coi đúng ko, làm vậy cho nó nhanh.

  5. #5
    Thợ cả biết tuốt's Avatar
    Ngày tham gia
    Nov 2013
    Đang ở
    Hanoi, Vietnam, Vietnam
    Bài viết
    1,356
    Cám ơn
    534
    Được cám ơn 437 lần ở 319 bài viết
    vâng thank các bác ,
    Driver của em tự chế dùng L297 + IR2104+ IRF z44 , photon cách ly dùng TPL 521
    BOB cũng tự chế , dùng photton TPL521 cách ky rồi đến 74hc04 xuất ra step/dir
    em mới cho chạy thử lại đánh dấu gốc tọa độ , nó bị lệch tọa độ theo trục x , về gốc cũng bị dịch theo trục x
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	goc.JPG 
Views:	189 
Size:	50.9 KB 
ID:	715
    em sẽ chạy thử file bác vừa cho

  6. #6
    Spam killer ahdvip's Avatar
    Ngày tham gia
    Nov 2013
    Đang ở
    Ho Chi Minh City, Vietnam, Vietnam
    Bài viết
    934
    Cám ơn
    103
    Được cám ơn 562 lần ở 304 bài viết
    Cách mình tốt phết, kaka. Máy bị sai lệch rồi đâu cần chạy thử file đó nữa, coi kiểm tra kĩ coi nguyên nhân đc rồi.
    NGUYỄN NGỌC ĐỨC - cncquangnam@gmail.com - DĐ: 0989315944
    TK Techcombank: 19026797927015 (Tân Bình, HCM)

  7. #7
    Thợ bậc 3
    Ngày tham gia
    Oct 2013
    Bài viết
    56
    Cám ơn
    45
    Được cám ơn 45 lần ở 18 bài viết
    Bác gõ tay mấy dòng code sau :

    G21
    G90
    G00 X10.0000 Y10.0000 z5

    rồi ve home xem .
    Chấp Nhận Thua 1 Trận Chiến Nhưng Sẽ Thắng Cả Cuộc Chiến .

  8. #8
    Thợ cả biết tuốt's Avatar
    Ngày tham gia
    Nov 2013
    Đang ở
    Hanoi, Vietnam, Vietnam
    Bài viết
    1,356
    Cám ơn
    534
    Được cám ơn 437 lần ở 319 bài viết
    có lẽ bác CKD nói đúng bị mất bước khi đảo chiều ,vì chạy theo trục y nó cũng bị như vậy

  9. #9
    Thợ bậc 6 CKD's Avatar
    Ngày tham gia
    Nov 2013
    Bài viết
    4,409
    Cám ơn
    940
    Được cám ơn 3,749 lần ở 1,902 bài viết
    Vậy bạn có thể post sơ đồ ko? Xem có thể tìm được nguyên nhân.
    Phạm Duy Anh - Email: phamduyanh@gmail.com - DT: O9O8984O1O - CKD's Youtube Channel -> click here - Facebook
    121A Mậu Thân, p.Xuân Khánh, q.Ninh Kiều, tp CT

  10. #10
    Nam Sờ Pín
    Ngày tham gia
    Nov 2013
    Bài viết
    5,111
    Cám ơn
    1,376
    Được cám ơn 2,917 lần ở 1,806 bài viết
    Chạy nhanh cũng bị lệch, chạy chậm cũng bị lệch và chạy ngang theo x hoặc theo Y cũng lệch ? nếu thử tất cả mà vẫn lệch thì bác nên mươn thùng điều khiển hay thay drive hàng chính hãng thử xem, em nghi ngờ cái drive và BOB tự chế của bác quá.

  11. #11
    Thợ bậc 6 vietnamcnc's Avatar
    Ngày tham gia
    Nov 2013
    Bài viết
    479
    Cám ơn
    161
    Được cám ơn 397 lần ở 227 bài viết
    Xem lại độ rơ của vít me đi bạn!

    (vít me - motor, vít me bạc đỡ, đai ốc bi và chỗ gá, đai ốc bi và vít me)

  12. Thành viên đã cám ơn vietnamcnc cho bài viết hữu ích này:


  13. #12
    Thợ cả biết tuốt's Avatar
    Ngày tham gia
    Nov 2013
    Đang ở
    Hanoi, Vietnam, Vietnam
    Bài viết
    1,356
    Cám ơn
    534
    Được cám ơn 437 lần ở 319 bài viết
    bá cáo em thấy nguyên nhân rồi ạ
    do em không để ý , hồi mới chế cứ lắp thấy quay quay là tưởng ok ,thế là vứt xó đó
    L297 đảo chiều bằng tín hiệu xung , cứ có xung là nó đảo chiều , CW/CWW mode
    còn tín hiệu xuất ra từ LPT là dạng step / dir , tức khi đảo chiều nó chuyển từ mức 1-0
    thế nên driver của em nó khi nhận tín hiệu dảo chiều nó không đảo ngay mà bị trễ 1 lúc đều đều , nên mới hình thành ruộng bậc thang
    thank các bác

  14. #13
    Thợ bậc 6 vietnamcnc's Avatar
    Ngày tham gia
    Nov 2013
    Bài viết
    479
    Cám ơn
    161
    Được cám ơn 397 lần ở 227 bài viết
    Trích dẫn Gửi bởi biết tuốt Xem bài viết
    bá cáo em thấy nguyên nhân rồi ạ
    do em không để ý , hồi mới chế cứ lắp thấy quay quay là tưởng ok ,thế là vứt xó đó
    L297 đảo chiều bằng tín hiệu xung , cứ có xung là nó đảo chiều , CW/CWW mode
    còn tín hiệu xuất ra từ LPT là dạng step / dir , tức khi đảo chiều nó chuyển từ mức 1-0
    thế nên driver của em nó khi nhận tín hiệu dảo chiều nó không đảo ngay mà bị trễ 1 lúc đều đều , nên mới hình thành ruộng bậc thang
    thank các bác
    Ha ha! Bị rơ điện tử!

    Còn nếu bị rơ cơ khí như tớ nói thì cũng ra ruộng bậc thang như vậy đấy!

  15. #14
    Thợ bậc 6 CBNN's Avatar
    Ngày tham gia
    Nov 2013
    Bài viết
    499
    Cám ơn
    357
    Được cám ơn 275 lần ở 150 bài viết
    kiếm cái driver chuẩn thay vào test là biết ngay thôi ah .

  16. #15
    Thợ phụ bậc 1
    Ngày tham gia
    Nov 2013
    Bài viết
    13
    Cám ơn
    6
    Được cám ơn 4 lần ở 4 bài viết
    Hiện tượng này máy mình đã gặp. Bạn setup gia tốc cao lên là hết (tất nhiên là giảm tốc độ). Và nó chỉ bị với những loại motor chạy điện áp thấp hoặc xét tốc độ cao. Đặc biệt vit me bước lớn là hay bị nhất. Nó cũng giống như là mình chạy một hình chữ nhật bằng dao 3mm thì theo nguên tắc góc hình chữ nhật có đường kính 3mm, nhưng sản phẩm chạy ra lại có góc đường kính lớn hơn 3mm.
    Không biết có đúng không... ?
    Lần sửa cuối bởi hoangmobiado, ngày 13-11-2013 lúc 10:04:12 PM.
    Tel: 0966898808 - Email: hoangmobiado@yahoo.com

  17. Thành viên đã cám ơn hoangmobiado cho bài viết hữu ích này:


  18. #16
    Thợ cả biết tuốt's Avatar
    Ngày tham gia
    Nov 2013
    Đang ở
    Hanoi, Vietnam, Vietnam
    Bài viết
    1,356
    Cám ơn
    534
    Được cám ơn 437 lần ở 319 bài viết
    hiện tượng này do em dùng chưa đúng con cách ly quang ở DRIVER , bị hỏng ossilocope nên dùng đại con c817 đáng phải dùng 6N137 Click vào ảnh để xem ảnh lớn hơn. 

Name:	6N137-circuits.jpg 
Views:	155 
Size:	14.0 KB 
ID:	1824 bác nào tự chế nghịc chú ý cái này là DRIVER ok

  19. #17
    Thợ cả
    Ngày tham gia
    Nov 2013
    Bài viết
    4,474
    Cám ơn
    1,823
    Được cám ơn 2,500 lần ở 1,588 bài viết
    Trích dẫn Gửi bởi hoangmobiado Xem bài viết
    Hiện tượng này máy mình đã gặp. Bạn setup gia tốc cao lên là hết (tất nhiên là giảm tốc độ). Và nó chỉ bị với những loại motor chạy điện áp thấp hoặc xét tốc độ cao. Đặc biệt vit me bước lớn là hay bị nhất. Nó cũng giống như là mình chạy một hình chữ nhật bằng dao 3mm thì theo nguên tắc góc hình chữ nhật có đường kính 3mm, nhưng sản phẩm chạy ra lại có góc đường kính lớn hơn 3mm.
    Không biết có đúng không... ?
    cái này thì nghiên cứu chức năng CV mode của mach3
    http://www.machsupport.com/wp-conten...ettings_v2.pdf

    b.r

  20. Thành viên đã cám ơn nhatson cho bài viết hữu ích này:


  21. #18
    Học việc
    Ngày tham gia
    Feb 2014
    Bài viết
    5
    Cám ơn
    0
    Được cám ơn 0 lần ở 0 bài viết
    Trích dẫn Gửi bởi biết tuốt Xem bài viết
    thưa các bác em đang trong giai đoạn vọc artcam , bản em dùng là artcam pro 9 và mach3 v 3.20
    em gặp cái lỗi như sau:
    em khoét thử 1 hình vuông 10x10cm , sâu 8mm
    các bước em làm trong art : dùng công cụ Area clear để khoét , và chạy ngang theo trục x (Raster =0)
    lúc máy chạy nó bị dịch trục x dần đều sang bên trái , để lại như rộng bậc thang
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	loi.JPG 
Views:	1 
Size:	1.14 MB 
ID:	709
    em tưởng DRiver của em bị lỗi em kiểm tra , đổi trục này sang trục kia vẫn rứa --> chán đnag định mua đồ mới về thử
    ai dè em lại cho nó khoét lại và chạy theo trục y (Raster =90)
    thế là lần này trục x ngon trục y bị lỗi như trục x , như vậy có nghĩa là driver của em không sao
    vậy các bác chỉ cho em biết là do artcam lỗi hay mach3 lỗi vậy?
    còn một lỗi nữa của mach3 là đang chạy mà em ấn Estop , sau đó reset và ấn star thì nó nhẩy đi 20 dòng lệnh rồi chạy chứ không chạy ở dòng vừa dừng là sao các bác nhỉ???
    Cung co the la do khop noi bi long do ban, xem ky lai di. loi doi khi do phan co khi nua ban

  22. #19
    Thợ bậc 6 mig21's Avatar
    Ngày tham gia
    May 2014
    Bài viết
    354
    Cám ơn
    347
    Được cám ơn 106 lần ở 71 bài viết
    Máy e cũg bị vậy, mò bên cái cv mode cả ngày mới chạy ok, đây là thông số của e

  23. #20
    Thợ bậc 6 conga's Avatar
    Ngày tham gia
    Oct 2014
    Đang ở
    Thanh Liêm-Hà Nam
    Bài viết
    378
    Cám ơn
    224
    Được cám ơn 83 lần ở 75 bài viết
    M542 đi là hết à thím.
    Công Lãng Tử - Zalo: 0126.614.O988 -Tel: O98.115.68.58

Trang 1 của 2 12 CuốiCuối

Các Chủ đề tương tự

  1. ý tưởng làm máy laser co2 giao diện mach3
    Bởi th11 trong diễn đàn Máy laser CNC
    Trả lời: 16
    Bài viết cuối: 14-12-2015, 02:32:55 AM
  2. Lỗi khi truy cập cncprovn.com
    Bởi vndic trong diễn đàn Đóng góp phát triển
    Trả lời: 6
    Bài viết cuối: 01-12-2013, 11:09:22 PM
  3. Artcam ebook
    Bởi phuong786 trong diễn đàn Phần mềm ART
    Trả lời: 3
    Bài viết cuối: 22-11-2013, 07:52:13 AM
  4. Trả lời: 4
    Bài viết cuối: 08-11-2013, 10:59:37 PM

Quyền viết bài

  • Bạn Không thể gửi Chủ đề mới
  • Bạn Không thể Gửi trả lời
  • Bạn Không thể Gửi file đính kèm
  • Bạn Không thể Sửa bài viết của mình
  •