1. Chú ý: Các bạn nên tham khảo Nội quy trước khi viết bài (click vào liên kết bên dưới).
    * Nội quy và Thông báo diễn đàn CNCProVN.com
    * Nếu bạn thấy hứng thú với bài viết. Hãy dùng chức năng Share to facebook để chia sẻ bài viết lên facebook.

Mẫu banner quảng cáoMẫu banner quảng cáoMẫu banner quảng cáoMẫu banner quảng cáo
          
Kết quả 1 đến 16 của 16

Chủ đề: Giúp đỡ Set up auto Z zero

  1. #1
    Thợ bậc 6
    Ngày tham gia
    Nov 2013
    Bài viết
    501
    Cám ơn
    150
    Được cám ơn 170 lần
           ở 133 bài viết

    Giúp đỡ Set up auto Z zero

    Tập tành rồi đâm ra ghiền lúc nào không biết, định dựng máy đơn giản chơi thôi nhưng rãnh rỗi lại mày mò tập tành Set auto Z zero nhưng sao vướng chỗ BOB không nhận được Input, nhờ mấy cao thủ gỡ rối tơ lòng giúp với.
    Khoe chút thành quả trước
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	IMAG0414.jpg 
Views:	1 
Size:	1.76 MB 
ID:	6392
    Đấu nối phần cứng thế náy:
    [IMG][/IMG]
    Set up Pin/port thế này:
    [IMG][/IMG]
    Set up xong không có tín hiệu gì thử hết các input còn lai cũng im ru luôn, quẫn quá làm auto set up như thế này:
    [IMG][/IMG]
    Cũng không có kết quả, mọi người giúp với

  2. #2
    Thợ bậc 7 Khoa C3's Avatar
    Ngày tham gia
    Nov 2013
    Đang ở
    Hải Dương
    Bài viết
    1,235
    Cám ơn
    273
    Được cám ơn 738 lần
           ở 351 bài viết
    Bác không cấp điện cho nó à?
    Zalo: 0975 826 040. Nguyen Van Khoa 131 2128 6777 016 NH Techcombank HD.

  3. #3
    Thợ bậc 6
    Ngày tham gia
    Nov 2013
    Bài viết
    501
    Cám ơn
    150
    Được cám ơn 170 lần
           ở 133 bài viết
    Tất nhiên là có chứ,không có điện thì nói làm gì, máy chạy rồi mà chưa có nút nhấn nào hết

  4. #4
    Thợ bậc 7 Khoa C3's Avatar
    Ngày tham gia
    Nov 2013
    Đang ở
    Hải Dương
    Bài viết
    1,235
    Cám ơn
    273
    Được cám ơn 738 lần
           ở 351 bài viết
    Theo hình vẽ trên thì bác không cấp nguồn cho thiết bị gắn vào input.
    Zalo: 0975 826 040. Nguyen Van Khoa 131 2128 6777 016 NH Techcombank HD.

  5. Thành viên đã cám ơn Khoa C3 cho bài viết hữu ích này:


  6. #5
    Thợ cả
    Ngày tham gia
    Jul 2014
    Bài viết
    2,066
    Cám ơn
    469
    Được cám ơn 530 lần
           ở 399 bài viết
    Bác Khoa nói đúng à, bác nối con trở pull up ( tầm 4,7K-10k) vào chân input ( kéo lên nguồn 5v nhé).
    Tel: 0387 8 Năm 85 Sáu 5

  7. Thành viên đã cám ơn anhxco cho bài viết hữu ích này:


  8. #6
    Thợ cả Diyodira's Avatar
    Ngày tham gia
    Oct 2014
    Bài viết
    1,632
    Cám ơn
    366
    Được cám ơn 664 lần
           ở 452 bài viết
    Mấy bác bình tĩnh, về cơ bản chưa biết probe là lọai gì, theo hình vẽ nếu là công tắc hành trình thì đúng rồi, kiểm tra lại dây nhợ, software thôi
    Lần sửa cuối bởi Diyodira, ngày 05-03-2015 lúc 09:13:59 AM.

  9. #7
    Thợ bậc 6
    Ngày tham gia
    Nov 2013
    Bài viết
    501
    Cám ơn
    150
    Được cám ơn 170 lần
           ở 133 bài viết
    Trích dẫn Gửi bởi anhxco Xem bài viết
    Bác Khoa nói đúng à, bác nối con trở pull up ( tầm 4,7K-10k) vào chân input ( kéo lên nguồn 5v nhé).
    Ý Bác là thế này đúng không
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	So do board dem Mach3 Analog_zps8gpha0sr.jpg 
Views:	238 
Size:	65.7 KB 
ID:	6398

  10. #8
    Thợ cả
    Ngày tham gia
    Jul 2014
    Bài viết
    2,066
    Cám ơn
    469
    Được cám ơn 530 lần
           ở 399 bài viết
    Trích dẫn Gửi bởi maxx.side Xem bài viết
    Ý Bác là thế này đúng không
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	So do board dem Mach3 Analog_zps8gpha0sr.jpg 
Views:	238 
Size:	65.7 KB 
ID:	6398
    Đúng rùi bác à.
    Tel: 0387 8 Năm 85 Sáu 5

  11. Thành viên đã cám ơn anhxco cho bài viết hữu ích này:


  12. #9
    Thợ bậc 6 CKD's Avatar
    Ngày tham gia
    Nov 2013
    Bài viết
    6,651
    Cám ơn
    1,716
    Được cám ơn 5,283 lần
           ở 2,588 bài viết
    Theo hình thì nên đấu thế này, vì đầu vào là opto có +/-, không rỏ trên BOB đã nối +/- chung chưa, nên kho có hướng dẫn chính xác. Thường thì khi đưa vào trạng thái có +/- thì.
    - IN5- --> GND
    - IN5+ --> điện trở 470om -> +5VDC (nếu trên BOB đã có điện trở thì có thể không cần điện trở này).
    - IN5+ --> probe
    -----> Active low
    Cách khác.
    - GND --> tool
    - IN5- --> probe
    - IN5+ --> điện trở 470om -> +5VDC (nếu trên BOB đã có điện trở thì có thể không cần điện trở này).
    -----> Active hight
    DT: O7837277II - CKD's Youtube Channel - Facebook - Tổng hợp chủ đề
    17 ds 3, Thạnh Mỹ Lợi, Q2, tp.HCM

  13. Thành viên đã cám ơn CKD cho bài viết hữu ích này:


  14. #10
    Thợ phụ bậc 2
    Ngày tham gia
    Nov 2013
    Đang ở
    Hà Nội
    Bài viết
    31
    Cám ơn
    0
    Được cám ơn 3 lần
           ở 3 bài viết
    Mình thì đấu thế này:
    5v BOB --> in5+
    GND --> 1 sợi dây
    In5- --> probe ( xài 1 LED+ 1 trở)
    Mình Vân làm vậy và OK

  15. Thành viên đã cám ơn DUYCNC cho bài viết hữu ích này:


  16. #11
    Thợ cả
    Ngày tham gia
    Jul 2014
    Bài viết
    2,066
    Cám ơn
    469
    Được cám ơn 530 lần
           ở 399 bài viết
    Nhiều ý kiến quá, e thấy bác CKD nói tổng quát nhất á, e chưa dùng bob nên quên mất là có thêm con opto.
    Tel: 0387 8 Năm 85 Sáu 5

  17. #12
    Thợ bậc 6
    Ngày tham gia
    Nov 2013
    Bài viết
    501
    Cám ơn
    150
    Được cám ơn 170 lần
           ở 133 bài viết
    Sau sự chỉ dẫn tận tình của các anh em, cuối cùng cũng làm được, cảm ơn tất cả mọi người

  18. #13
    Thợ bậc 6 CKD's Avatar
    Ngày tham gia
    Nov 2013
    Bài viết
    6,651
    Cám ơn
    1,716
    Được cám ơn 5,283 lần
           ở 2,588 bài viết
    Quan trọng là làm thế nào để đạt kết quả. Bạn đã đấu nối thế nào?
    DT: O7837277II - CKD's Youtube Channel - Facebook - Tổng hợp chủ đề
    17 ds 3, Thạnh Mỹ Lợi, Q2, tp.HCM

  19. Thành viên đã cám ơn CKD cho bài viết hữu ích này:


  20. #14
    Thợ bậc 6
    Ngày tham gia
    Nov 2013
    Bài viết
    501
    Cám ơn
    150
    Được cám ơn 170 lần
           ở 133 bài viết
    Mạch BOB có opto cách ly nên phải đấu thêm 5 V+ vào IN+, que dò và tấm mẫu lần lược là IN- và GND, nhân đây gởi mọi người code set Z thấy đơn giản và dễ hiểu :
    'VB Code Start
    '-------------------
    CurrentFeed = GetOemDRO(818)
    DoSpinStop()

    ZMove = 20.00 'Total lenght of Probe to move before Stop or no Contact Made.
    ZOffset = 1.60 ' Plate Hight
    ZSal = ZOffset + 2.00 '+ Free Hight, Will possition the Proble 2 MM over the Material.

    StopZmove = 0
    If GetOemLed (825)=0 Then
    DoOEMButton (1010)
    Code "G4 P2.5"
    Code "G31 Z-"& ZMove & "F25"
    While IsMoving()
    Sleep(200)
    Wend
    Probepos = GetVar(2002)
    If Probepos = - ZMove Then
    responce = MsgBox ("**ERROR** " , 4 , "Probe **ERROR**" )
    Code "G0 Z10"
    StopZmove = 1
    Code "F" &CurrentFeed
    End If
    If StopZmove = 0 Then
    Code "G0 Z" & Probepos
    While IsMoving ()
    Sleep (200)
    Wend
    Call SetDro (2, ZOffset)
    Code "G4 P1"
    Code "G0 Z" & ZSal
    Code "(Z zeroed)"
    Code "F" &CurrentFeed
    End If
    Else
    Code "(Check Ground Probe)"
    End If
    Exit Sub
    '-------------------
    'VB Code Stop

  21. Thành viên đã cám ơn maxx.side cho bài viết hữu ích này:

    CKD

  22. #15
    Thợ bậc 6
    Ngày tham gia
    Nov 2013
    Bài viết
    557
    Cám ơn
    55
    Được cám ơn 196 lần
           ở 123 bài viết
    Em chạy NCSTUDIO V5 và có có sẵn chức năng để sử dụng Z tool.
    Chỉ việc đấu mát vào máy để mát thông ra mũi dao. Mua một cái miếng set nó sẽ có sẵn đầu nối ra chỉ việc nối vào chân z tool.
    Khai báo độ dày của miếng set Z đó.
    Chỉ việc nhấn Ctrl+F7 là xong.

  23. Có 2 thành viên đã cám ơn suu_tam cho bài viết hữu ích này:


  24. #16
    Thợ bậc 6
    Ngày tham gia
    Nov 2013
    Bài viết
    382
    Cám ơn
    313
    Được cám ơn 37 lần
           ở 32 bài viết
    Trích dẫn Gửi bởi suu_tam Xem bài viết
    Em chạy NCSTUDIO V5 và có có sẵn chức năng để sử dụng Z tool.
    Chỉ việc đấu mát vào máy để mát thông ra mũi dao. Mua một cái miếng set nó sẽ có sẵn đầu nối ra chỉ việc nối vào chân z tool.
    Khai báo độ dày của miếng set Z đó.
    Chỉ việc nhấn Ctrl+F7 là xong.
    bác khai báo độ dày ở mục nào ạ. máy còn bị lỗi khi ấn ctrl+f7 , thì z chạy lên . xin hỏi các bác cách khắc phục ạ

Các Chủ đề tương tự

  1. [Giúp đỡ] Nghịch ngu với vitme :(
    Bởi namrex trong diễn đàn Vít me, thanh răng, ray trượt, trục trượt, vòng bi, gối đở...
    Trả lời: 48
    Bài viết cuối: 02-03-2015, 03:47:47 PM
  2. Mong anh em giúp đỡ
    Bởi tien_classic trong diễn đàn Trao đổi kinh nghiệm
    Trả lời: 13
    Bài viết cuối: 17-12-2014, 09:12:09 AM
  3. Giúp đỡ dùng dao
    Bởi solero trong diễn đàn Dụng cụ cắt gọt
    Trả lời: 15
    Bài viết cuối: 03-07-2014, 01:34:47 PM

Tag của Chủ đề này

Quyền viết bài

  • Bạn Không thể gửi Chủ đề mới
  • Bạn Không thể Gửi trả lời
  • Bạn Không thể Gửi file đính kèm
  • Bạn Không thể Sửa bài viết của mình
  •