1. Chú ý: Các bạn nên tham khảo Nội quy trước khi viết bài (click vào liên kết bên dưới).
    * Nội quy và Thông báo diễn đàn CNCProVN.com
    * Nếu bạn thấy hứng thú với bài viết. Hãy dùng chức năng Share to facebook để chia sẻ bài viết lên facebook.

Mẫu banner quảng cáoMẫu banner quảng cáoMẫu banner quảng cáoMẫu banner quảng cáo
          
Kết quả 1 đến 20 của 20

Chủ đề: Nhờ các bác bắt bệnh step tự chạy cà dựt

  1. #1
    Thợ cả ngocsut's Avatar
    Ngày tham gia
    Nov 2014
    Bài viết
    1,569
    Cám ơn
    713
    Được cám ơn 103 lần
           ở 90 bài viết

    Nhờ các bác bắt bệnh step tự chạy cà dựt

    Mong các bác bốc thuốc giùm, em đánh vật với cái driver mãi nó mới có dấu hiệu chạy nhưng step tự động quay 1 chiều và cà dựt ngay khi bật nguồn (chưa chạy chương trình gì cả).
    Tình trạng hiện tại:


    Nhưng khi tháo cáp từ BOB sang driver thì step nằm im, em nghi là vấn đề ở thằng Bob nhưng không rõ đấu sai chỗ nào

    Thành phần:
    1. Bob tàu, cấp điện 5v từ cổng USB máy tính
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	BOB.JPG 
Views:	1 
Size:	148.8 KB 
ID:	6814

    2. Driver IM483, sơ đồ đi kèm
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	driver.png 
Views:	2 
Size:	408.6 KB 
ID:	6815

    3. Nguồn máy tính đểu đã nối dây chạy offline, điện áp ra 12V, 5V

    Click vào ảnh để xem ảnh lớn hơn. 

Name:	IMG_0929.JPG 
Views:	129 
Size:	66.3 KB 
ID:	6816
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	IMG_0930.JPG 
Views:	128 
Size:	65.6 KB 
ID:	6817
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	IMG_0931.JPG 
Views:	126 
Size:	68.9 KB 
ID:	6818
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	IMG_0932.JPG 
Views:	128 
Size:	72.0 KB 
ID:	6819
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	IMG_0933.JPG 
Views:	125 
Size:	69.4 KB 
ID:	6820
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	IMG_0934.JPG 
Views:	123 
Size:	73.3 KB 
ID:	6821

  2. #2
    Thợ cả
    Ngày tham gia
    Jul 2014
    Bài viết
    3,390
    Cám ơn
    1,574
    Được cám ơn 1,032 lần
           ở 799 bài viết
    Có lẽ bác thiếu dây nối Gnd từ Bob sang driver

  3. Thành viên đã cám ơn thuhanoi cho bài viết hữu ích này:


  4. #3
    Thợ cả
    Ngày tham gia
    Feb 2014
    Bài viết
    1,715
    Cám ơn
    337
    Được cám ơn 539 lần
           ở 356 bài viết
    Chạy 1 chiều là do nhầm pul sang dir, đảo lại trong mach3 hoặc dây. Cà rựt thì kiểm tra lại có thể nhầm dây pha động cơ
    Lê Anh Tuấn - 0989.bốn không 8. 4 0 tám

  5. Thành viên đã cám ơn emptyhb cho bài viết hữu ích này:


  6. #4
    Thợ cả
    Ngày tham gia
    Feb 2014
    Bài viết
    1,715
    Cám ơn
    337
    Được cám ơn 539 lần
           ở 356 bài viết
    Giờ mới xem video và đọc kỹ lại bài của bác. Nhue video thì chắc chắn bác đang đấu nhầm dây của động cơ rồi
    Lê Anh Tuấn - 0989.bốn không 8. 4 0 tám

  7. #5
    Thợ cả ngocsut's Avatar
    Ngày tham gia
    Nov 2014
    Bài viết
    1,569
    Cám ơn
    713
    Được cám ơn 103 lần
           ở 90 bài viết
    Trích dẫn Gửi bởi emptyhb Xem bài viết
    Giờ mới xem video và đọc kỹ lại bài của bác. Nhue video thì chắc chắn bác đang đấu nhầm dây của động cơ rồi
    cảm ơn tuấn nhiều nhé, chú đúng là thánh đoán nhầm
    tớ vừa đảo các kiểu: đảo pul-dir từ bob sang, đảo các đầu dây motor (tất nhiên vẫn đúng cặp) mà chả khác gì

  8. #6
    Thợ cả ngocsut's Avatar
    Ngày tham gia
    Nov 2014
    Bài viết
    1,569
    Cám ơn
    713
    Được cám ơn 103 lần
           ở 90 bài viết
    Trích dẫn Gửi bởi thuhanoi Xem bài viết
    Có lẽ bác thiếu dây nối Gnd từ Bob sang driver
    tức là nối dây GND của bob vào chân GND bất kỳ của driver ạ?

  9. #7
    Thợ cả
    Ngày tham gia
    Feb 2014
    Bài viết
    1,715
    Cám ơn
    337
    Được cám ơn 539 lần
           ở 356 bài viết
    Trích dẫn Gửi bởi ngocsut Xem bài viết
    tức là nối dây GND của bob vào chân GND bất kỳ của driver ạ?
    Haha, cũng có thể là nhầm, step của bác 6 dây, của em có 4 dây thôi. Ngày trước em cũng từng bị một lần như thế nên phán như đúng rồi
    Lê Anh Tuấn - 0989.bốn không 8. 4 0 tám

  10. #8
    Thợ cả
    Ngày tham gia
    Feb 2014
    Bài viết
    1,715
    Cám ơn
    337
    Được cám ơn 539 lần
           ở 356 bài viết
    Mà em nhìn cái ảnh bob với driver đặt sát nhau thế? Không khéo mấy chân đằng sau bob lại bị chập
    Lê Anh Tuấn - 0989.bốn không 8. 4 0 tám

  11. #9
    Thợ cả
    Ngày tham gia
    Jul 2014
    Bài viết
    3,390
    Cám ơn
    1,574
    Được cám ơn 1,032 lần
           ở 799 bài viết
    Trích dẫn Gửi bởi ngocsut Xem bài viết
    tức là nối dây GND của bob vào chân GND bất kỳ của driver ạ?
    Lấy cái dây GND (bên cạnh pin 5V) của Driver nối với kẹp cà sấu kẹp vào cái vỏ cổng USB trên BOB test thử đi nhé

  12. Thành viên đã cám ơn thuhanoi cho bài viết hữu ích này:


  13. #10
    Thợ cả ngocsut's Avatar
    Ngày tham gia
    Nov 2014
    Bài viết
    1,569
    Cám ơn
    713
    Được cám ơn 103 lần
           ở 90 bài viết
    Trích dẫn Gửi bởi thuhanoi Xem bài viết
    Lấy cái dây GND (bên cạnh pin 5V) của Driver nối với kẹp cà sấu kẹp vào cái vỏ cổng USB trên BOB test thử đi nhé
    em thử rồi vẫn ko khác j a, motor kêu như bò

  14. #11
    Thợ cả ppgas's Avatar
    Ngày tham gia
    Mar 2014
    Đang ở
    TP.HCM
    Bài viết
    2,509
    Cám ơn
    1,422
    Được cám ơn 679 lần
           ở 378 bài viết
    Trước em bị tình trạng tương tự, bác để ý cái motor thứ 3 nhé:



    Nguyên nhân, đấu sai thứ tự các cặp dây.
    Bác thử đi lại theo hướng này xem.
    -- Ppgas - 09mộtba77năm14không --

  15. Thành viên đã cám ơn ppgas cho bài viết hữu ích này:


  16. #12
    Thợ cả
    Ngày tham gia
    Jul 2014
    Bài viết
    3,390
    Cám ơn
    1,574
    Được cám ơn 1,032 lần
           ở 799 bài viết
    Loại này bipolar nên chỉ dung 4 dây cho 2 cuộn dây động cơ thôi, nếu nhầm cuộn này qua cuộn kia thì sẽ không có điện qua động cơ --> động cơ không chạy; nếu nhầm thứ tụ cuộn dây thì động cơ sẽ chạy theo chiều này hoặc chiều kia hoàn toàn bình thường. Theo suy đoán (99,9%) là do nhiễu có thể do dây GND chưa đúng hoặc bo BOB nằm quá gần bo driver gây ra hiện tượng tự chạy

  17. Thành viên đã cám ơn thuhanoi cho bài viết hữu ích này:


  18. #13
    Thợ cả
    Ngày tham gia
    Feb 2014
    Bài viết
    1,715
    Cám ơn
    337
    Được cám ơn 539 lần
           ở 356 bài viết
    Loại 6 dây em thường thấy màu vàng với trắng là 2 dây hay bỏ đi không đấu, đây bác chủ đấu là sao nhỉ? có thể nhầm lẫn chỗ này không?
    Lần sửa cuối bởi emptyhb, ngày 25-03-2015 lúc 02:19:21 PM.
    Lê Anh Tuấn - 0989.bốn không 8. 4 0 tám

  19. Thành viên đã cám ơn emptyhb cho bài viết hữu ích này:


  20. #14
    Thợ cả
    Ngày tham gia
    Jul 2014
    Bài viết
    3,390
    Cám ơn
    1,574
    Được cám ơn 1,032 lần
           ở 799 bài viết
    Trích dẫn Gửi bởi emptyhb Xem bài viết
    Loại 6 dây em thường thấy màu vàng với trắng là 2 dây hay bỏ đi không đấu, đây bác chủ đấu là sao nhỉ? có thể nhầm lẫn chỗ này không?
    Đối với động cơ Unipolar 6 dây : hoàn toàn được bác à, có thể dùng toàn cuộn dây (bỏ dây vàng và trắng) hoặc dùng nửa cuộn (dùng dây vàng và trắng)

  21. Thành viên đã cám ơn thuhanoi cho bài viết hữu ích này:


  22. #15
    Thợ bậc 6
    Ngày tham gia
    Nov 2013
    Bài viết
    532
    Cám ơn
    63
    Được cám ơn 222 lần
           ở 151 bài viết
    Bác chủ nói là chưa chạy chương trình gì hết mà nó vẫn bị thì trước mắt xác định là nhiễu tín hiệu hoặc chạm dây đâu đó à, chừng nào tìm ra nguyên nhân, nối bob + driver + pc lại mà ok hết thì mới tính chuyện đấu dây motor đúng hay sai.

  23. Thành viên đã cám ơn lekimhung cho bài viết hữu ích này:


  24. #16
    Thợ cả ngocsut's Avatar
    Ngày tham gia
    Nov 2014
    Bài viết
    1,569
    Cám ơn
    713
    Được cám ơn 103 lần
           ở 90 bài viết
    cảm ơn các bác đã quan tâm.
    - về motor e thử cả 4 dây, 6 dây đều bị như vậy
    - về nguồn cấp, em dùng nguồn 12v chung cho driver và bob, nhưng loại trừ nhiễu do nguồn vì khi ko nối bob với driver thì motor nằm im. em cũng câu thử chân GND từ driver vào vỏ cổng USB thì motor nằm liệt luôn, chạy chương trình cũng ko động tĩnh j.
    - em cũng nghĩ là do nhiễu từ đâu đó, giờ chỉ chú ý 2 chỗ:
    + Bob em cắm trực tiếp vào cổng LPT, tuy không chạm vào đâu nhưng có thể sát máy tính nên bị nhiễu điện từ
    +3 cái chân pin khoanh tròn như hình, các bác xem 3 chân này em phải đấu vào đâu?
    Click vào ảnh để xem ảnh lớn hơn. 

Name:	BOB.JPG 
Views:	57 
Size:	85.2 KB 
ID:	6867

  25. #17
    Thợ cả
    Ngày tham gia
    Feb 2014
    Bài viết
    1,715
    Cám ơn
    337
    Được cám ơn 539 lần
           ở 356 bài viết
    Đấu 5v out thì bác lấy 1 cổng để đấu vào pul+ với dir + trên driver, như trên bản vẽ có 2 dây 5v đó bác
    Lê Anh Tuấn - 0989.bốn không 8. 4 0 tám

  26. Thành viên đã cám ơn emptyhb cho bài viết hữu ích này:


  27. #18
    Thợ cả ngocsut's Avatar
    Ngày tham gia
    Nov 2014
    Bài viết
    1,569
    Cám ơn
    713
    Được cám ơn 103 lần
           ở 90 bài viết
    kính thưa các bác em đã giải quyết đc vấn đề, motor đã hoạt động tuy còn kêu như game 4 nút nhưng cơ bản đã chạy theo chương trình. Set up hiện tại: bob em dùng nguồn từ cổng USB nối vào 2 pin PCGround và PC5V. Nhưng căn bản là phải câu 1 dây từ pin PCGround của bob (không phải là chân mát hay vỏ USB như bác thuhanoi chỉ dẫn) sang chân Ground của nguồn driver. Em đoán là như vậy điện áp 0V Ground của cả bob và driver sẽ đồng bộ hoàn toàn không bị rò điện qua nhau nữa.
    Cuối cùng em xin cảm ơn các bác đã nhiệt tình giúp đỡ

  28. #19
    Thợ cả
    Ngày tham gia
    Jul 2014
    Bài viết
    3,390
    Cám ơn
    1,574
    Được cám ơn 1,032 lần
           ở 799 bài viết
    Hi, chúc mừng bác đã thành công, mình thì BOB Mach3 có nhưng chưa sờ tới nữa chỉ chiếu theo BOB Planet mà phán - nhưng bác thấy có tương đồng không à

  29. #20
    Thợ cả ngocsut's Avatar
    Ngày tham gia
    Nov 2014
    Bài viết
    1,569
    Cám ơn
    713
    Được cám ơn 103 lần
           ở 90 bài viết
    hi em gà lần đầu thế là yomost lắm rồi chứ planet thì em chưa hình dung đc hình thù sao

Các Chủ đề tương tự

  1. Gửi các bác có máy chạy gỗ hay để qua đêm...
    Bởi solero trong diễn đàn Trao đổi kinh nghiệm
    Trả lời: 5
    Bài viết cuối: 21-07-2017, 10:40:19 PM
  2. các bác cho em hỏi máy tính xách tay IBM T40 có chạy Mach3 ổn định k?
    Bởi k123kien trong diễn đàn Tủ điều khiển & các vấn đề khác
    Trả lời: 5
    Bài viết cuối: 23-10-2015, 02:52:32 PM
  3. Driver alpha step nóng khi chạy không tải có sao không các bác?
    Bởi hardfarmer trong diễn đàn Driver Step motor
    Trả lời: 6
    Bài viết cuối: 08-05-2015, 05:57:44 PM
  4. Driver step bị lỗi nhờ cao thủ chỉ bệnh.
    Bởi C.Frame trong diễn đàn Thắc mắc
    Trả lời: 4
    Bài viết cuối: 22-03-2015, 09:42:01 AM
  5. Chào các bác, nhờ các bác giúp đỡ về BOB Mach3 5 trục
    Bởi hardfarmer trong diễn đàn Board điều khiển khác
    Trả lời: 10
    Bài viết cuối: 28-11-2014, 04:26:03 PM

Quyền viết bài

  • Bạn Không thể gửi Chủ đề mới
  • Bạn Không thể Gửi trả lời
  • Bạn Không thể Gửi file đính kèm
  • Bạn Không thể Sửa bài viết của mình
  •